Creator

Synchronizing lyrics

The most important step in the process of creating karaoke songs is synchronizing the lyrics with the music. To allow the performer to sing along the words need to be highlighted as they should be sung.

 To synchronize the words you have typed in or imported use commands from Synchronize menu or buttons from synchronization group on the toolbar.

 The first step will usually be to synchronizing the entire song – to do this select Synchronize entire song button (image.png) or Synchronize entire song menu command. Program will enter the synchronization mode and the synchronization toolbar will appear. 

image.png


 The lyrics will be colored to visualize the current synchronization state – brown color marks the part of the lyrics that have already been synchronized, the white color highlights the word that is to be synchronized next, and gray is applied to the words that have not been synchronized yet.

 To synchronize the highlighted word you have to press the SPACE key or select the Set toolbar button at the moment that the word should be sung. The currently highlighted word will be marked as synchronized and the next word will become highlighted. You may pause and restart the playback using standard playback controls (Play, Pause, and Stop), and if you make a mistake you may press the Backspace key or select Back toolbar button. The last synchronized word will become unmarked. You may also move the playback position ten seconds backwards by pressing minus key or selecting Rewind toolbar button – all the synchronization information for the last ten seconds will be erased.

 If you make a mistake or for some other reason do not reach the end of the song in a single synchronization pass, fear not. You may continue the synchronization from the place you have stopped by selecting Continue synchronizing toolbar button (image.png) or menu command. If you want to redo the synchronization from the certain point, place the cursor there and select Synchronize from cursor toolbar button (image.png) or menu command. Note that all the synchronization information after the selected word will be deleted. One more possibility is to retry synchronizing one of the completed lines. To do this place the cursor in the line you want to redo and select Synchronize current line toolbar button (image.png) or menu command. All the synchronization information in the current line will be deleted, but all the rest of the song will remain as it is.

 

To check the results of the synchronization you need to make sure that Highlight lyrics during playback option is checked (this corresponds to pushed in Highlight during playback button on the lyrics panel toolbar image.png) and play the file. As the file is played back, the lyrics that should be sung are highlighted. Note that the words are highlighted letter-by-letter, so the singer can see how fast should the word be sung. During the playback you may move the cursor and the playback will resume from the selected word. 

If you find synchronization mistakes, there are two ways you may fix them:

Modifying word synchronization using soundtrack panel

Using Adjust current word dialog box

 


MODYFYING SYNCHRONIZATION USING SOUNDTRACK PANEL

Soundtrack panel can be used to adjust the start and the end of the word. This can be done in many ways.

To move the entire word click on the label and move it up and down. The word's duration will not be changed. The duration of the previous and the next word will be modified accordingly. You may not move the word earlier then the start of the previous word, and later than the end of the next word.


In this example you see mouse pointer on label 'good'.

 

To move the end of the word and the beginning of the next word position click and drag the word boundary (the red horizontal line).


In this example end of word 'a' and start of word 'good' would be adjusted.

 

To move the start/end of the word without moving the end of the previous/next word hold down the SHIFT, and then click and drag the word boundary.


Only the beginning of the word 'good' would be moved.


Only the end of the word 'good' would be moved.

 

To place a cursor over the label boundary keep the CTRL key down and click as if label was not there.

 


ADJUST CURRENT WORD DIALOG BOX

To adjust the synchronization of the word, click on the word in the lyrics editor (it will become underlined), and click Adjust current word toolbar button or select Adjust word synchronization menu command. You may also right-click the word and select Adjust word synchronization command from a pop-up menu.

image.png

 Adjust word synchronization dialog box will appear under the current word.

 Word placement displays current time for start and end of the word in seconds. To move them use buttons below.


 TIP: To change the amount that is added or subtracted to the time click on Settings button and modify Adjust amount value.


You may check the synchronization of the word using playback buttons.

Play and stop will start the playback before the word and and stop after it is highlighted. Program will highlight the word during playback.

Play in loop will continuously play current word.

By default the playback is started two words before current word and stopped one word after the current word. To modify this values click Settings and change Play before and Play after values. You may start several words earlier or enter a time value in seconds.

Stop button stops the playback.

 After you have adjusted the synchronization for the word you may close the dialog box using Close button, or you may move to the next or previous word using the appropriate buttons.

 


SHIFT LABELS

Shift Labels command from Edit menu allows to move all labels at once.

image.png

Offset is the value in milliseconds that will be used to move all labels. Negative value moves labels backwards.

Create Song Manually

PowerWizard will help you to create your first karaoke song with Karaoke Creator.

Starting PowerWizard

To start PowerWizard click New Song Wizard toolbar button (image.png)  and choose Synchronize lyrics manually.

Soundtrack

The next step will be choosing the soundtrack to use for the song.

image.png


 To load the soundtrack click Browse button and navigate to the audio file you want to use.

After the file is loaded, its name and playback time will displayed in the wizard window. Karaoke Creator can use WAV and MP3 files as soundtracks. 

Remove Vocals

PowerWizard allows to remove vocals from the song. More information on removing vocals can be found in Removing vocals section.

image.png

To proceed to the next step click Next button.

Lyrics

Now it is time to provide lyrics for the song.

image.png


 There are several ways to add lyrics to the song. You may:

·    type lyrics in (you may listen to the song as you type -- use Play button to control the playback)

·    use web search for lyrics; Karaoke Creator automatically opens browser window and runs search using provided details (song title and artist name); more on lyrics search can be found in section Search for lyrics on the web

·    paste lyrics from the clipboard (you may select the lyrics in web browser or text editor, copy it, and then paste it into Karaoke Creator)

·    import lyrics from the text file

To proceed to the next step click Next button.

Synchronizing lyrics

This step is the most difficult in the whole process of karaoke song creation. You have to synchronize the lyrics to the music.

image.png

 During synchronization process Karaoke Creator highlights words one by one, and your task is to tap the space bar at the moment the word is sung. It is not simple and takes some experience to achieve. To start synchronizing press Start synchronizing button. The first word in the song will become highlighted and the song will start to play.

When the song reaches the highlighted word, press Space key on your keyboard. The highlighting will move to the next word and so on. To mark the end of the word (usually before the long instrumental break) press Ctrl key. When you are done (ie. all words have been synchronized press Enter key or click Done button).

Now you need to check how good job have you done. To do this click Test button and see if the words highlight correctly during playback. Please note that if you have not done perfect job you may adjust synchronization later (see Adjusting synchronization section).

 As you have probably noticed synchronizing lyrics is not an easy task. Here are hints that can make your life easier:

·    use speed control to decrease the playback speed; if you select 0.5 the playback will be two times slower

·    use Go Back button if you miss the beat; Rewind buttons rewinds the playback, but does not move highlighting

·    if you are working on a new song, synchronize it from start till end, and then do it once more; second pass will be much better

·    see Advanced synchronization for synchronization tips

 

To proceed to the next step click Next button.

 Wizard is done

The wizard is complete -- most of the work is done.

image.png


 You are left with three choices now. You may:

·    Apply a visual style to the song -- this button will open Styles dialog that will allow you to use one of song templates

·    Adjust synchronization or edit the song -- choosing this option will let you to fine tune the song, edit lyrics, or fix synchronization errors

·    Create file will take you directly to file creation

If Save the song before continuing is checked, you will be prompted to save the song. Karaoke Creator saves song in PK3 files. Note that saving files is disabled in demo mode.

Main window

On the top you see common Windows interface items -- menu bar and toolbar.

 Left side of the window is occupied by the soundtrack panel. It displays a waveform of the current soundtrack, and on top of it labels that correspond to the synchronized words.

 Right side of the window contains the shortcut bar. It contains shortcuts to most frequently used commands. Shortcut bar changes with context -- if you do not need it any more you may close (to display it again use Shortcut bar command from View menu). To leave the shortcut bar visible, but to disable animations, select Preferences from File menu and uncheck Animate shortcut bar option.

The main area of the screen is taken by the lyrics editor. It consists of two parts -- preview window on the top (you may close is with Preview toolbar button ) and lyrics area below.

 Preview window displays the CD+G preview of the current part of the lyrics -- this is how your song will look on the TV screen. If your computer is slow, rendering preview make take a long time and your work will be uncomfortable. To avoid this either hide the preview window or disable automatic updates (clicking Update button will render the preview at the current cursor position).

 Lyrics area allows to edit the lyrics text, insert CD+G events, and adjust synchronization of the words.

Style

To apply a predefined visual style to your song click Styles button on the toolbar ({DC368090-BAB1-4DE9-85D3-1AAFD5C6FF2B}.png) or select Styles command from Create menu.

image.png

 Song details section of the dialog box allows you to enter title of the song, artist name, and text that will be displayed as your company information (probably something like Presented to you by DOBLON). Credits are displayed after the song is finished.

                Tip: To force a new line in Title, Artist, or Company name fields, use ^ character.

 

What is style?

Karaoke Creator allows to set styles for:

·    Title: image displayed before the song

·    Credits: image displayed after the song is finished

·    Song: colors, text formatting, page layout, and image (in Pro version only) of the lyrics

 

Each of this styles can be applied individually, or it is possible to use presets.

 Style preset combo box allows to select one of predefined templates. It will change all styles in Applied styles. You may store your combination of Title, Song, and Credit styles using Add button. To save changed combination use Save button. Delete button removes your preset from the list.

 Applied styles lists styles used for each of the sections of the song. To change the style select it in Applied styles list and then choose the new style from Available styles combo. Selecting (Unused) will disable the style.

 Style editor button starts Style Editor dialog box which allows you to create your own styles.

 Preview window displays the preview of the style selected in Applied styles list.

 Selected styles will be applied to the song when you select OK button.

 To continue with the tutorial select Rock style preset and click OK button.

Import an existing CD+G file

One of the most exciting features of Karaoke Creator is the ability to import existing CD+G songs. This allows you to re-edit commercial editions of karaoke songs with endless possibilities — change fonts and images, fix broken characters, modify lyrics, or create parodies. Karaoke Creator imports both lyrics and synchronization, so the most cumbersome part of song creation is already done, leaving you to focus on the fun.

To import a CD+G song, select the Import CD+G File command from the File menu or click the Import CD+G File button on the toolbar.

image.png

First, you need to select a file containing CD+G songs. Two file formats are supported: CDG and BIN. If you use a CDG file, Karaoke Creator will automatically look for an MP3 file of the same name and use it as a soundtrack.

If the Insert 'Clear Screen' events automatically option is checked, Karaoke Creator will detect when the entire screen is erased in the CD+G song and will insert 'Clear Screen' events at the same places in the imported song. This helps maintain text flow for page-by-page songs.

The import process may take a while (up to half a minute on a slower computer). Once completed, you will see the imported lyrics in the lyrics editor. Please check for spelling mistakes, as some characters may be recognized incorrectly.


NOTE:

  1. Not every song can be imported. Duets are not supported, and songs using scrolling will not import.
  2. Optical Character Recognition (OCR) is not perfect and may occasionally make errors. Please check the lyrics for spelling mistakes.

Import MIDI Karaoke

MIDI files are ideal for karaoke because they do not contain vocals and are widely available online. Many MIDI files also include synchronized lyrics. The most common file extension for MIDI karaoke files is KAR, but many MID files also contain lyrics.

Karaoke Creator includes an Import MIDI Karaoke Wizard to assist in converting MIDI karaoke files to CD+G format.

To start the wizard, select the Import MIDI Karaoke Wizard command from the Import MIDI section in the File menu.


Select Files

image.png

You must provide the input KAR file. Use the [...] button next to the input file field to locate the file you want to convert.

The wizard will create a WAV file from the MIDI song. By default, this WAV file is saved in the same directory as the source KAR or MID file. Use the [...] button next to the output file field to change the directory if needed.

There are two ways to convert MIDI

We recommend using the latter, as it gives very good results and does not provide issues with hardware management


Lyrics Import

After importing the audio, Karaoke Creator automatically imports the lyrics. If issues occur during this process, an error message will be displayed.


Done

You have successfully imported a MIDI karaoke file. You now have a synchronized soundtrack and lyrics, ready to edit further.

Create song with duets

Karaoke Creator gives you the tools to create professional duets. Most important duet features are: 

·    Duet Wizard that helps to assign lyrics to singers

·    Full Duet synchronization mode

·    Divided CD+G screen for duets (Singer 1 at top and Singer 2 at the bottom of the screen)

 

In this tutorial we will show you how to create a song that can be sing by two singers, each of them singing different words at the same time.


 To understand this tutorial you need to be familiar with creating songs with Karaoke Creator, so if you are just starting please see Create karaoke song with PowerWizard tutorial first.

 

Starting up

In this tutorial we will use a traditional song Brother John. Soundtrack and lyrics can be found in Examples subfolder of My Karaoke folder in Documents. Please create a new song by clicking on New button on the toolbar or selecting New command from File menu. If you are using PowerWizard, select Create a new song from scratch (without PowerWizard) on the first wizard screen.

 Now load the soundtrack using Load soundtrack button on the toolbar. The soundtrack file is brother john.mp3. Then load the lyrics from the text file -- use Import lyrics toolbar button or Import lyrics from a text file command from File menu. Lyrics file is brother john.txt. You may save the first version of the song at this point.

image.png

Defining duets

The next step it to assign portions of the lyrics to each of the singers. As you have probably noticed the song lyrics consists of 5 repeated verses, while the music contains the same verse 4 times only. We will start with both singers singing the first verse together, then Singer 1 will sing two verses with Singer 2 joining in, but half of the verse later. And the last verse will be sung together by both.

 To assign lyrics to singers we will use Duet Wizard.

To start it click Duet Wizard button on the toolbar (image.png) or select Duet Wizard from Edit menu.

 image.png

 Lyrics assigned to Singer 1 are red, lyrics assigned to Singer 2 are blue, and those that should be sung together are grey.

 To assign a part of the lyrics to particular singer (or to both singers) select this part in the lyrics window (drag mouse to select the text) and then click Selection button next to the singer mode you want to use. Duet Wizard always uses full lines, so if you position the cursor in the middle of the line and then click Selection, entire line will be assigned.

 From cursor to end buttons allow to assign all song lyrics from the current cursor position to the end of the song to one of the duet modes.

 Set all will assign entire song to one of the modes.

 After you close Duet Wizard with OK you will see that Duet events have been inserted in the text of the song.

image.png

 Please note that you can enter Duet Wizard many times and the current duet assignments will be the starting point for further editing.

 

 

Synchronization

Now it is time to synchronize the lyrics.

To do this we need to enter full duet mode. To do this click Full duet mode button on the toolbar (image.png) or select Enable full duet mode from Synchronize menu. Duet tab control will appear above the lyrics editor.

image.png

Duet tabs allow switching between duet modes. No duets is for editing lyrics -- it displays the entire text of the song. The other three are for each of the duet roles.

Selecting Singer 1 tab will activate Singer 1 duet mode. It will dim the lyrics that are not assigned for Singer 1 and preview will show Singer 1 lyrics only.

Duet tabs are used to synchronize the duet song. Unfortunately synchronizing duet songs takes three times as long as regular songs -- you have to synchronize part for both singers, and then individual parts for each of the two singers.

To continue with the tutorial try synchronizing the lyrics with the music. Select Both duet tab, click Synchronize entire song button on the toolbar, and synchronize the first and the last verse of the song. Then select Singer 1 tab, click Synchronize entire song button again and synchronize the second and the third verse. And finally synchronize Singer 2 -- this time start in the middle of the second verse.

 Please note that synchronization labels in the soundtrack panel are not visible in No duets mode -- you need to activate one of the duet tabs to display and edit them.

 

Settings

To adjust the settings for duets double-click any of the duet events (Duet dialog box will appear) and select Duet settings button to open Duet settings dialog box.

image.png

Here you can define the text settings for Singer 1 and Singer 2 -- just select the mode on the top and adjust the settings. Please note that the number of lines apply to half of the screen only (Singer 1 uses the upper part and Singer 2 uses the lower part of screen). Settings for Both singers mode are copied from general settings.

 

Create file

We are nearly done. All that is left is to create a CD+G file and to see if everything plays correctly. This is important, as sometimes, because of synchronization errors, some text may overlap.

To create a CDG file click Create CD+G File toolbar button (). You may leave all settings at default values -- simply click OK and see the result.

 If you have missed any of the steps you may load the final file -- it is brother john4.pk2.

 

Duets without screen split

If you do not wish to split the screen between two singers and rather have words for both singers displayed one after another, disable Full duet mode before creating karaoke file. Also the lyrics for both singers should interleave -- they need to be in the same order as they should be displayed (so in general this will be like duets in PowerKaraoke, but with concurrent highlighting.

 

 We have prepared an example that shows this -- it is brother john no split.pk2 file.

Soundtrack panel

Soundtrack panel contains a waveform view of the soundtrack and on top of it displays synchronized lyrics labels.

 

File details

Top of the soundtrack panel contains the name and the length of the current soundtrack file. Also current cursor position and zoom are displayed.

Zoom

Zoom corresponds to the number of samples shown by one pixel. Zoom 1000 means that every pixel on the waveform display represents 1000 samples. Karaoke soundtracks have frequency of 44100 samples per second, so at zoom 1000 44 pixels represent one second of music.

Use the arrows to modify the zoom. Higher values will show more of the screen on the file, increasing the density. Lower values will give more detail.

Preview bar

Preview bar is displayed on the left. It represents an entire file. The current part of the soundtrack is represented by a window on the preview bar.

Click anywhere in the preview bar to position the cursor.

Use arrows to move back and forth in the soundtrack.

You may extend the visible window by dragging its edges (see image above). It has the same result as changing zoom value.

Click at the bottom of the visible window and drag it to move the window.

Cursor

The horizontal yellow line is a cursor. It represents current position in the file. When you play the music the cursor will move. Click anywhere on the waveform or on the preview bar to move the cursor to the new location.

Labels

Labels are synchronized words. The horizontal red lines are start and end points. Label is attached to the start point.

Soundtrack panel can be used to adjust the start and the end of the word. This can be done in many ways.

To move the entire word click on the label and move it up and down. The word's duration will not be changed. The duration of the previous and the next word will be modified accordingly. You may not move the word earlier then the start of the previous word, and later than the end of the next word.


In this example you see mouse pointer on label 'good'.

 

To move the end of the word and the beginning of the next word position click and drag the word boundary (the red horizontal line).


In this example end of word 'a' and start of word 'good' would be adjusted.

 

To move the start/end of the word without moving the end of the previous/next word hold down the SHIFT, and then click and drag the word boundary.


Only the beginning of the word 'good' would be moved.


Only the end of the word 'good' would be moved.

 

To place a cursor over the label boundary keep the CTRL key down and click as if label was not there.

 

Soundtrack panel - labels

Soundtrack panel can be used to adjust the start and the end of the word. This can be done in many ways.

To move the entire word click on the label and move it up and down. The word's duration will not be changed. The duration of the previous and the next word will be modified accordingly. You may not move the word earlier then the start of the previous word, and later than the end of the next word.


In this example you see mouse pointer on label 'good'.

 

To move the end of the word and the beginning of the next word position click and drag the word boundary (the red horizontal line).


In this example end of word 'a' and start of word 'good' would be adjusted.

 

To move the start/end of the word without moving the end of the previous/next word hold down the SHIFT, and then click and drag the word boundary.


Only the beginning of the word 'good' would be moved.


Only the end of the word 'good' would be moved.

 

To place a cursor over the label boundary keep the CTRL key down and click as if label was not there.

 

Shortcut bar

Shortcut bar contains shortcuts to most frequently used commands of Karaoke Creator. Shortcut bar changes with context -- if you do not need it any more you may close (to display it again use Shortcut bar command from View menu). Shortcut bar is especially helpful when you start learning how to work with Karaoke Creator.

Lyrics editor

Lyrics editor allows you to edit lyrics, synchronize them, and to insert events in the text that control how your song will look like.

Lyrics editor is a simple text editor window with additional color information that describe word's synchronization status.

Grey text represents lyrics that are not synchronized


Brown text represents lyrics that are already synchronized


White text represents an active word during synchronization process.

 

During playback white is used to sweep the words.


 When lyrics are synchronized lyrics editor displays one more information -- the current word. It is represented by the underline. To change the current word simply click it. The current word's label is automatically selected in the soundtrack panel.

Entering lyrics



IMPORT LYRICS FROM TEXT FILE

To import lyrics from the text file use Import lyrics toolbar button or choose Import lyrics from a text file command from File menu. 


IMPORT LYRICS FROM MIDI KARAOKE FILE

MIDI Karaoke files contain lyrics already synchronized with music. To import lyrics from MIDI Karaoke file use Import lyrics from MIDI Karaoke file command from File menu. If the MIDI file contains multiple lyrics tracks, the longest track will be used.


PASTE LYRICS

Lyrics editor provides standard copy and paste functionality. You may use it to transfer the lyrics of the song from the text processing application or web browser.

 To paste the lyrics into Karaoke Creator:

1.   Activate the source application (web browser or word processor)

2.   Select the lyrics text

3.   Copy it to the clipboard (CTRL+C)

4.   Activate Karaoke Creator, click into the lyrics editor in and paste the lyrics (use CTRL+C keyboard shortcut, Paste toolbar button), or Paste command from Edit menu)

5.   Lyrics will be inserted at the current cursor position.

 

Playback controls

image.png


Start

Ctrl+1

Starts the playback from current cursor position

image.png


Pause

Ctrl+2

Pauses the playback and resumes it

image.png


Stop

Ctrl+3

Stops the playback. Cursor stays at the last played position.

image.png


Rewind

Ctrl+4

Moves the playback position 10 seconds backwards

image.png


Forward

Ctrl+5

Moves the playback position 10 seconds forward

image.png


Playback speed

 

Allows to change the playback speed

image.png 

 

Play from start

Ctrl+6

Moves the cursor to the start of the file and starts the playback

 

Play current word

Ctrl+7

Plays the current word (starts 1 second before and ends 1 second after)

 

Play current word (loop)

Ctrl+8

Plays the current word in loop

 Important information:

If you start dragging word labels during playback, Karaoke Creator enters word adjustment mode. It will loop around current label position, allowing you to get perfect synchronization. This feature can be controlled in Tools / Settings under Synchronization / Loop playback when dragging labels. You may adjust the time margin that will be used for playback.

Working with soundtracks

The soundtrack is background music that plays during your karaoke song. It can be an instrumental recording, a real song with vocals removed, or a MIDI song converted into an appropriate format. You can work with soundtracks in MP3 or WAV formats.

To choose the soundtrack, click Load Primary Soundtrack on the toolbar or select the Load Primary Soundtrack command from the File menu. Karaoke Creator can use up to three soundtracks:

Loaded soundtracks can be changed using the Current Soundtrack button (image.png) or the Current Soundtrack command from the Play menu.

The soundtrack is displayed in the Soundtrack Panel. To play the soundtrack, use the toolbar buttons or commands from the Play menu. For more details on playing files, see the Playback Controls section.

To replace the soundtrack with a different file, choose the Load Soundtrack command again for that soundtrack. All synchronization information will be retained.


Playback Controls

To play the soundtrack, use the toolbar buttons or commands from the Play menu. During playback, the cursor moves as the playback position changes. Also, if the Highlight lyrics during playback option in the Synchronize menu is selected, Karaoke Creator highlights words in the lyrics editor.

image.png


Start

Ctrl+1

Starts the playback from current cursor position

image.png


Pause

Ctrl+2

Pauses the playback and resumes it

image.png


Stop

Ctrl+3

Stops the playback. Cursor stays at the last played position.

image.png


Rewind

Ctrl+4

Moves the playback position 10 seconds backwards

image.png


Forward

Ctrl+5

Moves the playback position 10 seconds forward

image.png


Playback speed

 

Allows to change the playback speed

image.png 

 

Play from start

Ctrl+6

Moves the cursor to the start of the file and starts the playback

 

Play current word

Ctrl+7

Plays the current word (starts 1 second before and ends 1 second after)

 

Play current word (loop)

Ctrl+8

Plays the current word in loop

 Important information:

If you start dragging word labels during playback, Karaoke Creator enters word adjustment mode. It will loop around current label position, allowing you to get perfect synchronization. This feature can be controlled in Tools / Settings under Synchronization / Loop playback when dragging labels. You may adjust the time margin that will be used for playback.


TIP: If the song is fast-paced and you have trouble synchronizing it, use a lower playback speed. Note that the sound might be slightly distorted.

Writing CD+G files

Click Create CD+G File button on the toolbar ({3CA035F6-F5E4-423B-93FD-8ACA41FB741B}.png) or select Create CD+G File command from Create menu. You may also press F2 key on the keyboard.

image.png

 If you want to write this track to a CD, you need to select BIN as the output type. Selecting CDG output type will allow you to preview the result in Power CD+G Player. By default the output file is created in the same directory as the soundtrack file. Make sure that you have all necessary user privileges, or change the output file location.

 Please note that most of the settings is the same as those in CD+G Settings dialog box.

 If you would like to preview the output file, make sure that Open in Power CD+G Player when done option is checked. You may select a different software CD+G player if you have one -- use Choose player button to do this.

 Tip: If Siglos Karaoke Player/Recorder is installed on your computer, you will be prompted to use it as a default CD+G player in AI Karaoke CD+G Creator. 
Click here to visit Siglos Karaoke Player/Recorder website
.

 Now click OK to create CD+G file.

Playing CD+G files

Power CD+G Player can be used to play the tracks you create with Karaoke CD+G Creator.


 It is a good idea to view the song in full before burning it to the CD.

Video settings

Input/Output

 

Input

Here you can define the audio track that will be used in the video and choose the background image or video.

 There are three possible options for background. You may use a video or image file of your choice, you may use one of the predefined scrolling backgrounds (they are located in %APPDATA%/Doblon/Karaoke Video Creator/Backgrounds folder), or you may use a solid background.

 

Output

This defines the location of video file that will be created. You may choose the format of the video:

AVI

Windows video file format. Use to play on computer or on DivX-capable players

MPEG

Universal video format. Use for DVD creation and iPod and iPhone files

FLV

Flash video. Use for web

If Run default video player when done Karaoke Video Creator will open the newly created file and play it using system's default player for AVI files..

 

Compression

 

Video

This section defines video compression and frame rate. Compression button allows to choose from video encoders that are installed in the system.

 With MPEG encoding selected you may choose one of the predefined MPEG encoding presets (VideoCD, DVD, iPod, iPhone) or choose custom format and adjust all encoding parameters.

 

 

Audio

Choosing MP3 will result in audio channel encoded to MP3. You may change MP3 encoding parameters with Settings button.

Choosing ACM allows to choose from Audio Compression Manager codecs installed on your computer. Use Settings button to select the encoder and adjust the parameters.

 

Display

 

Width/Height

Defines the resolution of the created video. Set text area button allows to define which part of the video should be used to display lyrics. You may use Common sizes list to quickly select one of common resolutions.

Display mode

You may also select the text display mode. Choosing Page by page will result in the standard paged display. Overwrite will disable the screen erasing and the new words will overwrite the already sang. And Scrolled mode will generate the long flow of text that will move upwards with the highlighted line always in the middle. Half by half will cause lyrics to appear in turns at the top and at the bottom half of the screen.

 

Mode information on display modes can be found in Display modes section.

Squeeze text and do not break lines

When this option is selected Karaoke Video Creator will not break lines -- it will resize it horizontally so every line fits the screen. This may help placing the text in the song, but if the lines are too long may decrease the readability of the text.

Vertical alignment

Allows to change the placement of the lines of the text. You may select Center, Top, or Bottom which would place the text at the appropriate part of the screen, or choose Space evenly, which makes sure that the first line is at the top, the last at the bottom, and all the spaces between the lines are equal.

Horizontal alignment

This setting controls the way the individual lines of text are placed. You have the choice of Center, Left, and Right.

Font

This setting specifies which font will be used for the lyrics and how large the letters should be. If you are trading you PK2 files make sure that you use fonts that are installed on the destination computer.

Colors

Allows to change the background, border and text color. Simply choose the appropriate color from the list or use More button to select the custom color.

Lines per screen

Allows to specify the maximum number of lines to be shown. Note that if the font size is too large, the actual number of lines may be lower.

Number of highlighted lines to keep

If using scrolling or overwrite display mode this parameter controls the number of lines that have already been sung but are not erased yet.

Additional spacing

The number of pixels to insert between the lines.

Outline/Shadow

This values control the effect added to the text. Setting them to zero disables the effect. The color of the text effects can be set in Colors dialog box.

Word fade time

To make the video look better words are faded in when displaying and faded out when erasing. This value controls the time fade takes.

Line scroll time

This value defines the time used to scroll the lyrics in scrolling display mode.

Highlight mode

Here you can select whether word should be simply swept with the color or somewhat nicer 'fade' effect should be used.

Syllable separator

Allows to select the character that separates syllables in the song text. By default the syllable separator is a hyphen (-).

Hard space

This option allows to change the default character that will be displayed as a space, but does not split the word (e.g. hard_space will be treated as a single word). By default the hard space character is an underline (_).

Gradient

To make the lyrics look better %APPNAME% applies gradient effect to the text it displays. This setting allows to control the intensity of the effect.

Apply blur

If you would like to blur the final image, you may define the level of blur to apply.

Pan background images with aspect ratio above X

If an image selected for the background is at least twice as wide as it is tall, %APPNAME% will scroll it from left to right and back. This creates a very nice visual effect. You may define the speed of the animation. We have provided a set of wide images to use as backgrounds, they are installed with the program.

 

Title/Credits

This group of options allows to select the pictures that are to appear before the song and after the song. By default these pictures are disabled.

To learn more about using images in Karaoke Video Creator see Images section.

 

Presets

You may save a current set of options and use it later for different song using the Save button. To invoke the preset select if from a pop-down list. To delete the existing preset use Delete button.

 If you would like to use current settings every time you start the program, click Use current as default button. You may also revert to this saved default settings using Reset to default button. It is also possible to revert settings to factory defaults.

Removing vocals

Power Vocal Remover is a tool that allows removing a lead vocal from a stereo recording. It bases on a common technique used in song mastering – lead vocal is usually mixed equally between both stereo channels.

To start AI Vocal Remover click AI Vocal Remover button on the toolbar (image.png) or select AI Vocal Remover from Toolbox menu.

image.png

 

Files

Here you may select the input and the output of the processing. By default the input file is the current soundtrack and the output name is created by appending –music to the input name. You may also create a vocal-only track (it will have -vocal added to the name).

Output folder is where the files will be written to. 

Output format

You may create MP3 or WAV files. For MP3 format it is possible to adjust encoding parameters.

Processing mode

You may choose one of two processing modes, we recommend using Best, but if it does not work or is too slow, try Normal or Highest.
Keep backing vocals will run additional processing that tries to retain background harmonies, doubles, and other supporting vocal layers while removing the main vocal

Full duet synchronization

To do this we need to enter full duet mode. To do this click Full duet mode button on the toolbar (image.png) or select Enable full duet mode from Synchronize menu. Duet tab control will appear above the lyrics editor.

image.png

Duet tabs allow switching between duet modes. No duets is for editing lyrics -- it displays the entire text of the song. The other three are for each of the duet roles.

Selecting Singer 1 tab will activate Singer 1 duet mode. It will dim the lyrics that are not assigned for Singer 1 and preview will show Singer 1 lyrics only.

Duet tabs are used to synchronize the duet song. Unfortunately synchronizing duet songs takes three times as long as regular songs -- you have to synchronize part for both singers, and then individual parts for each of the two singers.

To continue with the tutorial try synchronizing the lyrics with the music. Select Both duet tab, click Synchronize entire song button on the toolbar, and synchronize the first and the last verse of the song. Then select Singer 1 tab, click Synchronize entire song button again and synchronize the second and the third verse. And finally synchronize Singer 2 -- this time start in the middle of the second verse.

 Please note that synchronization labels in the soundtrack panel are not visible in No duets mode -- you need to activate one of the duet tabs to display and edit them.

Duet settings

To adjust the settings for duets double-click any of the duet events (Duet dialog box will appear) and select Duet settings button to open Duet settings dialog box.

image.png

Here you can define the text settings for Singer 1 and Singer 2 -- just select the mode on the top and adjust the settings. Please note that the number of lines apply to half of the screen only (Singer 1 uses the upper part and Singer 2 uses the lower part of screen). Settings for Both singers mode are copied from general settings.

Duets without screen split

If you do not wish to split the screen between two singers and rather have words for both singers displayed one after another, disable Full duet mode before creating karaoke file. Also the lyrics for both singers should interleave -- they need to be in the same order as they should be displayed (so in general this will be like duets in PowerKaraoke, but with concurrent highlighting.

 

 We have prepared an example that shows this -- it is brother john no split.pk2 file.

Clear screen event

This event will cause a screen to be erased after the last word before the event becomes highlighted. 

image.png

 You may select the mode that will be used to clear the screen (the default Simple is the fastest and results in immediate screen erase). Reverse will cause the effect to be reversed (ie. Left to Right will become Right to Left).

Colors event

Colors event allows to change colors for text (both normal and highlighted), effects, background, and border.

image.png

 Colors change will affect all words after the event. We do not recommend changing background and border colors in the middle of the page, only after of immediately before Clear screen events.

Countdown event

Countdown event tells Karaoke Creator to display a countdown marker before the next word is highlighted. In the current version of the program countdown marker is a string of dots.

image.png

 Countdown time defines the duration of the countdown (2 seconds by default).

 Number of items is the number of characters to display.

 Use repeated character select the default mode of repeating the single character several times. You may change the character used in Character to use field.

 Use text allows to enter text that will be used as a countdown. The text has to be entered into Text to use field.

Display image event

 File

You need to select the file containing the image. The following formats are supported:

To invoke the file selection dialog box select Browse button.

By default Karaoke Creator leaves the images on the hard disk and reads them when needed (Link to file option selected). This behavior reduces the size of PK3 files and allows making changes to the images using image editors (you do not have to visit the event again -- just edit the image and re-create the song). However if you delete the image file from disk, it will not be available.

 If you would like to share your PK3 files select Insert contents option. It will cause Karaoke Creator to include the image in PK3 file, so you may send it over to a friend or delete image files. Note that if image source file is deleted you will not be able to edit it any more.

Keep on screen for N seconds

This setting controls how long will the image be visible before it is erased. Note that painting time (up to 10 seconds for a full screen sized picture) and erasing is not included, so the total time that the picture takes equals to the sum of painting time, display time, and erase time.

 Selecting 0 will cause the image to become erased immediately after it is fully painted.

Border color

Choose the color that will surround the image. Note that it is different than Borders color setting in Colors event, as it refers to the area not taken by the image, and not only to the border of the screen. If you are using image as a background (in Set Text Area event) the background color must match the background color of the text.

Display mode and Erase mode

These settings control the way image is painted and erased. By default images are painted from left to right and erased immediately. You may change it by selecting any of the display effects.

 Checking the Reverse checkbox will cause the effect to run backwards, for example Left to Right mode will become to Right to Left.

 Note that selecting Fade and Simple as Display mode will cause the screen to go blank for several seconds (the image still needs to be painted, and this is done in a way that is not visible, yet still takes time).

Alignment

You may select the position of the picture if it is not full screen sized. Simply select the appropriate rectangle. By default images are centered.

Force scaling

This option will force the image to be scaled to the size defined in Width and Height boxes. This size cannot be larger than the full screen (288 x 192).

Dithering

If the number of colors in the image is larger than 16, Karaoke Creator will reduce it. You may select the algorithm that is used to make the image look as good as possible with the lower number of colors. Selecting none will disable any dithering. The simples way to see how each of the algorithms works is to select it and then to click the Preview button.

Resizing

This setting controls the way image is scaled if its size is not 288 x 192 (full screen).

Fit will cause the image to be scaled up or down to take as much screen as possible.

Fit if larger (default setting) will scale the image only if it is too large, it will not stretch it.

Crop will not scale the image and will display as much of it as possible.

 All resizing modes retain aspect ratio of the image.

Preview

Click this button to see how the picture will look.

Notes

·    Images with more colors take longer to paint.

·    Inserting image in the middle of the song may use up the time and cause the loss of synchronization.

 

Text settings event

Font

This setting specifies which font will be used for the lyrics and how large the letters should be. If you are trading you PK2 files make sure that you use fonts that are installed on the destination computer.

Vertical alignment

Allows to change the placement of the lines of the text. You may select Center, Top, or Bottom which would place the text at the appropriate part of the screen, or choose Space evenly, which makes sure that the first line is at the top, the last at the bottom, and all the spaces between the lines are equal.

Horizontal alignment

This setting controls the way the individual lines of text are placed. You have the choice of Center, Left, and Right.

Lines per screen

Allows to specify the maximum number of lines to be shown. Note that if the font size is too large, the actual number of lines may be lower.

Additional spacing

The number of pixels to insert between the lines.

Set Text Area event

 Note: This event is available in Pro version only.

 Using this event you may display the image and the text on screen at the same time. It also allows to change the portion of the screen that is used to display the lyrics.


 If you choose to display the image, it will be painted according to the selected options and will not be erased. The lyrics will appear at the defined area. Using this setting you may display the banner on the top of the text or an image anywhere on the screen.

 Clear screen or Display image event resets the text area to the full screen.

 Note: If the selected display mode is other than Overwrite, the image will be visible only on the first page.

 

 

Display image

Select the image you would like to appear on screen. You need to select the image file using Properties button before Display Image checkbox becomes active.

 Properties button will open Display image dialog box, the same as for Display Image event.

 Note that you the erase mode will not be used event if you define it, as the image will stay on screen.

Use all available area

Select this option if you want text to use all the screen that is not used by the image.

Copy to custom area

This button will set the custom area dimensions to the area not used by the image.

Define custom area

Using this option you may define the rectangle that will contain the lyrics. It may be useful if you want the lyrics to appear in the middle of the picture or simply move the text a little to the right. The full screen has width of 288 and height of 192 pixels.

 The custom area is visualized by the blue frame (black area represents full screen). You may modify it by dragging the edges of the frame.

Style editor

Style Editor allows you to create your own visual styles.

image.png

 Style editing is done in visual manner. The first step is to select the style type in Style type combo box (you may create Title, Song, and Credit styles). Once you select the style type Current style combo box is filled with available styles of the selected type.

 There are two types of styles -- system (predefined) styles and user-defined styles. Predefined styles have * in front of their names and cannot be altered.

 Once you select a style from the Current style combo box the style preview will be displayed in Preview window. Also fields available for the selected style type will be displayed on Available styles list. Each of the style types has different fields.

 For Title and Credit styles you may change the background image, colors, and define the position and properties of text fields. To change the position of the text field select it on the Available fields list. The field will be displayed as a light blue rectangle on the preview area. Use mouse to change the position. You may also change the font, color, and alignment of the text fields.

 Song style does not have a text field, but has lyrics field. You may define the properties of the lyrics using Lyrics properties button. If you would like to use settings defined for the current song, use Load from current song button.

 

Searching for MIDI karaoke on the web

Internet is full of MIDI karaoke files and Karaoke Creator provides a simple tool to help you find them.

 To start MIDI karaoke web search select Search the web for MIDI Karaoke command from File menu.

 

 Search engine combo allows you to change the place that you will use to search for files. You may try changing search engine if you are not getting the results you need.

 Clicking on OK button will open the search in your web browser. Once you find the file save it to your hard disc -- you may use it as a source to create karaoke file with Import MIDI Karaoke Wizard.

 Disclaimer: Doblon does not provide MIDI karaoke files. They are provided by various websites that are not affiliated with us.

Batch file create

Batch file create command from Create menu allows to write multiple files in one session.

 

 Use Add button to add PK2 files to the Input files list. Overwrite existing files without prompting will disable warning messages that might stop the batch process.

 Clicking OK will start processing. Please note that it may take a substantial amount of time if you add many files to the list.

 

Batch MIDI import

Sometimes it is necessary to convert several MIDI Karaoke songs into karaoke. This process cannot be fully automatized, however Karaoke Creator gives you the possibility to convert a batch of KAR songs without any user intervention. These songs can be opened and edited later to make sure they play correctly. Batch conversion saves time -- you do not have to select the songs and wait till they are recorded as WAV files, instead you choose the songs and let Karaoke Creator convert them all in a single process.

Important: Make sure that your MIDIs are converted correctly using Import MIDI Karaoke Wizard before using this feature.

To convert a batch of KAR songs select Batch MIDI Karaoke Convert command from the Import MIDI submenu of the File menu. Batch KAR Convertion dialog box will appear.

image.png


 Add the files to convert using Add button. Note that you may add several files at once.

 If you would like to remove any of the files, use Remove button.

 Output directory points to the directory that will contain all WAV, PK3 and output karaoke files (CD+G or Video, depending on the product) created during the convertion.

 If you do not want to be warned that files are getting overwritten, check Overwrite existing files without prompting.

 Checking Create .PK3 files option makes sure that every song is saved in .PK3 document. This option makes possible to open and edit converted files afterwards.

 Selecting Don't show error messages ensures uninterrupted processing, but may result in bad results if some of MIDI files contain errors.

Advanced lyrics import

 Import lyrics with timing command from Toolbox menu allows to import the lyrics stored in a text file along with the synchronization information.

 The sample text file might look like this:

 00:16.540 00:16.840 On

00:16.842 00:17.100 a

00:17.102 00:17.360 dark

00:17.362 00:17.660 desert

00:17.666 00:17.800 highway\n

00:19.010 00:19.300 Cool

00:19.429 00:19.521 wind

It contains the start and the end time of a word. The end of the line is marked by \n symbol.

 After the import is complete you may review the results by playing the file or inspecting time labels in the soundtrack panel.

image.png

Lyrics file

Select the text file containing the lyrics.

File preview

Here you can see the contents of the selected file.

Time format

Choose the appropriate time format. Following formats can be used:

MM:SS.TTT

minute:second.millisecond

milliseconds

milliseconds only

SS.TTT

second.millisecond

File format

Select the format of the file. Following settings are available:

Begin time only

File contains only the start time of the word

Begin and end times

File contains both the start and the end time of the word

Separator

Choose the separator between start time, end time, and text. The defaults are any space or tab characters.

Max word length

If no end time for the word is given, PowerKaraoke assumes that the ending time is the beginning time of the next word, but word duration cannot be longer than value specified by this option.

New line

Enter the text string that is used to mark a new line of text. By default it is '\n'.

Exporting lyrics

You may export lyrics from Karaoke Creator lyrics editor to the text file. To do this select Export lyrics command from Toolbox menu.

image.png

 Lyrics can be exported as a plain text (Lyrics only mode), they can contain starting time for the words (Lyrics and starting time mode), or both starting and ending time (Lyrics and full time mode).

 To write to Unicode text file make sure to select Use Unicode checkbox.

Adjusting program settings

To adjust Karaoke Creator settings, select Settings from the Tools menu.

Automatic countdowns

Automatic countdowns command from Edit menu allows to insert countdown event after every instrumental break of the specified length.

image.png

 Minimal break duration is a number of seconds of instrumental break after which countdown event will be inserted.

 Countdown settings allows to define settings for countdown events that will be inserted.

Text snippets

Often you may want to insert the same elements of the song multiple times into different songs. It may be your custom title page, instrumental break or a way you like to format song's chorus. You may use Text snippets to automate such tasks.

 Text snippet is a part of a song (lyrics and events) that can be reused. You may define as many text snippets as you like, you can also move them between computers.

 

To define a text snippet:

1.   Select the text you would like to save as a snippet

               

 

2.   Choose Text snippets from Edit window or right-click the selected text, choose Insert text snippet from a drop-down menu and then choose Edit snippets from a submenu

             

               

3.   Text Snippets window will open. You will see the text you have selected in the Preview field. Your snippet will be auto-named (you may change the name of the snippet by typing the new name in the name field and then clicking Rename button)

             

 

4.   You may switch between snippets by selecting them from the drop-down list. You may also remove currently selected snipped using Remove button.

5.   If you would like to insert a snippet using keyboard, you may define the hotkey for it. To do this use Assing hot key button. You may use combination of alphanumeric keys with SHIFT, ALT and CTRL.

6.   Selecting Close will save your snippet collection. Cancel will abandon the changes.

 

To insert a text snippet:

Position the cursor in the place you would like to insert the snippet and select Text snippets from Edit menu, choose the snippet to insert and click Insert

or

Right-click with your mouse and choose the snippet from Insert text snippet submenu

or

Use the hotkey defined for the snippet

 

To copy snippets to another computer:

Choose Export from Tools menu in Text snippets window. You will be able to choose a location of the file. All snippets will be saved. Move this file to a destination computer and choose Import there. You will be presented an option of replacing the snippets or appending them (with renaming if necessary).

Unlocking and evaluating

How do I unlock Karaoke Creator? 

To unlock Karaoke Creator you need to purchase the unlock code from Power Karaoke website. The unlock code will be delivered via email. Once you have it select Unlock command from Help menu.

The unlock code need to be copied or loaded from the text file. If it is accepted all limitations will be removed and you will see your name in the About dialog box. 

Search for Lyrics

Lyrics for most of the songs can be found on the internet. Karaoke Creator contains a helper tool that will run the search for lyrics online.

To search for the lyrics on the internet use choose Search the web for lyrics command from File menu.

image.png

You may enter the name of the artist, the title of the song, and part of the lyrics of the song (if you remember them).

Karaoke Creator uses internal lyrics sources to search for lyrics. If lyrics cannot be found, a browser window with Google search will open allowing you to copy and paste the lyrics.