Getting started User interface Main window   On the top you see common Windows interface items -- menu bar and toolbar.   Left side of the window is occupied by the soundtrack panel . It displays a waveform of the current soundtrack, and on top of it labels that correspond to the synchronized words.   Right side of the window contains the shortcut bar . It contains shortcuts to most frequently used commands. Shortcut bar changes with context -- if you do not need it any more you may close (to display it again use Shortcut bar command from View menu). To leave the shortcut bar visible, but to disable animations, select Preferences from File menu and uncheck Animate shortcut bar option. The main area of the screen is taken by the lyrics editor. It consists of two parts -- preview window on the top (you may close is with Preview toolbar button  ) and lyrics area below.   Preview window displays the CD+G preview of the current part of the lyrics -- this is how your song will look on the TV screen. If your computer is slow, rendering preview make take a long time and your work will be uncomfortable. To avoid this either hide the preview window or disable automatic updates (clicking Update button will render the preview at the current cursor position).   Lyrics area allows to edit the lyrics text, insert CD+G events, and adjust synchronization of the words. SOUNDTRACK PANEL Soundtrack panel contains a waveform view of the soundtrack and on top of it displays synchronized lyrics labels.   File details Top of the soundtrack panel contains the name and the length of the current soundtrack file. Also current cursor position and zoom are displayed. Zoom Zoom corresponds to the number of samples shown by one pixel. Zoom 1000 means that every pixel on the waveform display represents 1000 samples. Karaoke soundtracks have frequency of 44100 samples per second, so at zoom 1000 44 pixels represent one second of music. Use the arrows to modify the zoom. Higher values will show more of the screen on the file, increasing the density. Lower values will give more detail. Preview bar Preview bar is displayed on the left. It represents an entire file. The current part of the soundtrack is represented by a window on the preview bar. Click anywhere in the preview bar to position the cursor. Use arrows to move back and forth in the soundtrack. You may extend the visible window by dragging its edges (see image above). It has the same result as changing zoom value. Click at the bottom of the visible window and drag it to move the window. Cursor The horizontal yellow line is a cursor. It represents current position in the file. When you play the music the cursor will move. Click anywhere on the waveform or on the preview bar to move the cursor to the new location. Labels Labels are synchronized words. The horizontal red lines are start and end points. Label is attached to the start point. Soundtrack panel can be used to adjust the start and the end of the word. This can be done in many ways. To move the entire word click on the label and move it up and down. The word's duration will not be changed. The duration of the previous and the next word will be modified accordingly. You may not move the word earlier then the start of the previous word, and later than the end of the next word. In this example you see mouse pointer on label 'good'.   To move the end of the word and the beginning of the next word position click and drag the word boundary (the red horizontal line). In this example end of word 'a' and start of word 'good' would be adjusted.   To move the start/end of the word without moving the end of the previous/next word hold down the SHIFT , and then click and drag the word boundary. Only the beginning of the word 'good' would be moved. Only the end of the word 'good' would be moved.   To place a cursor over the label boundary keep the CTRL key down and click as if label was not there.   SHORTCUT BAR Shortcut bar contains shortcuts to most frequently used commands of Karaoke Creator. Shortcut bar changes with context -- if you do not need it any more you may close (to display it again use  Shortcut bar command from View menu). Shortcut bar is especially helpful when you start learning how to work with Karaoke Creator.   LYRICS EDITOR Lyrics editor allows you to edit lyrics, synchronize them, and to insert events in the text that control how your song will look like. Lyrics editor is a simple text editor window with additional color information that describe word's synchronization status. Grey text represents lyrics that are not synchronized Brown text represents lyrics that are already synchronized White text represents an active word during synchronization process.   During playback white is used to sweep the words.   When lyrics are synchronized lyrics editor displays one more information -- the current word. It is represented by the underline. To change the current word simply click it. The current word's label is automatically selected in the soundtrack panel.   There are several ways of providing lyrics to Karaoke Video Creator. You may:   Type the lyrics in   Import lyrics from the text file Import lyrics from MIDI karaoke file Paste the lyrics from the clipboard Search for lyrics on the internet   Lyrics editor allows to synchronize lyrics with music. For more information please see Synchronizing lyrics section. Entering lyrics The most obvious way to enter lyrics is to type them in. To do this activate the lyrics editor by clicking on it and start typing. You may listen to the song -- to start the playback use buttons on the toolbar. Karaoke Creator provides more ways of entering lyrics. You may:   Import lyrics from the text file Import lyrics from MIDI karaoke file Paste the lyrics from the clipboard Search for lyrics on the internet IMPORT LYRICS FROM TEXT FILE To import lyrics from the text file use  Import lyrics toolbar button  or choose Import lyrics from a text file command from File menu.   IMPORT LYRICS FROM MIDI KARAOKE FILE MIDI Karaoke files contain lyrics already synchronized with music. To import lyrics from MIDI Karaoke file use  Import lyrics from MIDI Karaoke file command from File menu.   If the MIDI file contains multiple lyrics tracks, the longest track will be used. PASTE LYRICS Lyrics editor provides standard copy and paste functionality. You may use it to transfer the lyrics of the song from the text processing application or web browser.   To paste the lyrics into Karaoke Creator : 1. Activate the source application (web browser or word processor) 2. Select the lyrics text 3. Copy it to the clipboard ( CTRL+C ) 4. Activate Karaoke Creator, click into the lyrics editor in and paste the lyrics (use  CTRL+C  keyboard shortcut, Paste toolbar button ), or Paste command from Edit menu) 5. Lyrics will be inserted at the current cursor position.   Working with soundtracks The soundtrack is background music that plays during your karaoke song. It can be an instrumental recording, a real song with vocals removed, or a MIDI song converted into an appropriate format. You can work with soundtracks in MP3 or WAV formats. To choose the soundtrack, click Load Primary Soundtrack on the toolbar or select the Load Primary Soundtrack command from the File menu. Karaoke Creator can use up to three soundtracks: Primary : Complete song. Vocal-removed : Song without vocals. Vocal-only : Contains only singing. Loaded soundtracks can be changed using the Current Soundtrack button ( ) or the Current Soundtrack command from the Play menu. The soundtrack is displayed in the Soundtrack Panel . To play the soundtrack, use the toolbar buttons or commands from the Play menu. For more details on playing files, see the Playback Controls section. To replace the soundtrack with a different file, choose the Load Soundtrack command again for that soundtrack. All synchronization information will be retained. Playback Controls To play the soundtrack, use the toolbar buttons or commands from the Play menu. During playback, the cursor moves as the playback position changes. Also, if the Highlight lyrics during playback option in the Synchronize menu is selected, Karaoke Creator highlights words in the lyrics editor. Start Ctrl+1 Starts the playback from current cursor position Pause Ctrl+2 Pauses the playback and resumes it Stop Ctrl+3 Stops the playback. Cursor stays at the last played position. Rewind Ctrl+4 Moves the playback position 10 seconds backwards Forward Ctrl+5 Moves the playback position 10 seconds forward Playback speed   Allows to change the playback speed     Play from start Ctrl+6 Moves the cursor to the start of the file and starts the playback   Play current word Ctrl+7 Plays the current word (starts 1 second before and ends 1 second after)   Play current word (loop) Ctrl+8 Plays the current word in loop   Important information: If you start dragging word labels during playback, Karaoke Creator enters word adjustment mode. It will loop around current label position, allowing you to get perfect synchronization. This feature can be controlled in  Tools /  Settings under  Synchronization /  Loop playback when dragging labels . You may adjust the time margin that will be used for playback. TIP : If the song is fast-paced and you have trouble synchronizing it, use a lower playback speed. Note that the sound might be slightly distorted. Synchronizing lyrics The most important step in the process of creating karaoke songs is synchronizing the lyrics with the music. To allow the performer to sing along the words need to be highlighted as they should be sung.   To synchronize the words you have typed in or imported use commands from Synchronize menu or buttons from synchronization group on the toolbar.   The first step will usually be to synchronizing the entire song – to do this select Synchronize entire song button ( ) or Synchronize entire song menu command. Program will enter the synchronization mode and the synchronization toolbar will appear.    The lyrics will be colored to visualize the current synchronization state – brown color marks the part of the lyrics that have already been synchronized, the white color highlights the word that is to be synchronized next, and gray is applied to the words that have not been synchronized yet.   To synchronize the highlighted word you have to press the SPACE key or select the Set toolbar button at the moment that the word should be sung. The currently highlighted word will be marked as synchronized and the next word will become highlighted. You may pause and restart the playback using standard playback controls ( Play , Pause, and Stop ), and if you make a mistake you may press the Backspace key or select Back toolbar button. The last synchronized word will become unmarked. You may also move the playback position ten seconds backwards by pressing minus key or selecting Rewind toolbar button – all the synchronization information for the last ten seconds will be erased.   If you make a mistake or for some other reason do not reach the end of the song in a single synchronization pass, fear not. You may continue the synchronization from the place you have stopped by selecting Continue synchronizing  toolbar button ( ) or menu command. If you want to redo the synchronization from the certain point, place the cursor there and select Synchronize from cursor toolbar button ( ) or menu command. Note that all the synchronization information after the selected word will be deleted. One more possibility is to retry synchronizing one of the completed lines. To do this place the cursor in the line you want to redo and select Synchronize current line toolbar button ( ) or menu command. All the synchronization information in the current line will be deleted, but all the rest of the song will remain as it is.   To check the results of the synchronization you need to make sure that Highlight lyrics during playback option is checked (this corresponds to pushed in Highlight during playback button on the lyrics panel toolbar  ) and play the file. As the file is played back, the lyrics that should be sung are highlighted. Note that the words are highlighted letter-by-letter, so the singer can see how fast should the word be sung. During the playback you may move the cursor and the playback will resume from the selected word.  If you find synchronization mistakes, there are two ways you may fix them: Modifying word synchronization using soundtrack panel Using Adjust current word dialog box   MODYFYING SYNCHRONIZATION USING SOUNDTRACK PANEL Soundtrack panel can be used to adjust the start and the end of the word. This can be done in many ways. To move the entire word click on the label and move it up and down. The word's duration will not be changed. The duration of the previous and the next word will be modified accordingly. You may not move the word earlier then the start of the previous word, and later than the end of the next word. In this example you see mouse pointer on label 'good'.   To move the end of the word and the beginning of the next word position click and drag the word boundary (the red horizontal line). In this example end of word 'a' and start of word 'good' would be adjusted.   To move the start/end of the word without moving the end of the previous/next word hold down the SHIFT , and then click and drag the word boundary. Only the beginning of the word 'good' would be moved. Only the end of the word 'good' would be moved.   To place a cursor over the label boundary keep the CTRL key down and click as if label was not there.   ADJUST CURRENT WORD DIALOG BOX To adjust the synchronization of the word, click on the word in the lyrics editor (it will become underlined), and click Adjust current word toolbar button  or select Adjust word synchronization menu command. You may also right-click the word and select Adjust word synchronization command from a pop-up menu.   Adjust word synchronization dialog box will appear under the current word.   Word placement displays current time for start and end of the word in seconds. To move them use buttons below.   TIP: To change the amount that is added or subtracted to the time click on Settings button and modify Adjust amount value. You may check the synchronization of the word using playback buttons. Play and stop will start the playback before the word and and stop after it is highlighted. Program will highlight the word during playback. Play in loop will continuously play current word. By default the playback is started two words before current word and stopped one word after the current word. To modify this values click Settings and change Play before and Play after values. You may start several words earlier or enter a time value in seconds. Stop button stops the playback.   After you have adjusted the synchronization for the word you may close the dialog box using Close button, or you may move to the next or previous word using the appropriate buttons.   SHIFT LABELS Shift Labels command from Edit menu allows to move all labels at once. Offset is the value in milliseconds that will be used to move all labels. Negative value moves labels backwards. Creating video files Before creating video file you need to make sure that your song looks good. Using Video Preview window   There are several ways of changing the appearance of karaoke video: Using styles Modifying video settings Using events   Once the song looks good you are ready to write it to video file. Writing video files   You may play video karaoke with any multimedia player installed on your computer.   Karaoke Video Creator does not burn DVD discs. To do this you need Karaoke DVD Burner. To learn move visit Karaoke DVD Burner website . USING VIDEO PREVIEW WINDOW Video preview window is located above the lyrics editor.     It displays the preview of the current part of the lyrics -- this is how your song will look on the TV screen. Please observe that the content of the preview window changes as you change the position of the cursor in the lyrics editor -- it always displays the page cursor is currently at. TIP: If your computer is slow, rendering preview make take a long time and your work will be uncomfortable. To avoid this either hide the preview window or disable automatic updates (clicking Update button will render the preview at the current cursor position). To view how lyrics will be highlighted click Video Preview button.  It allows to change the time of the preview snapshot -- the slider at the bottom of the window represents playing time. This window allows to preview how lyrics will look in the result video.   USING STYLES To apply a predefined visual style to your song click Styles button on the toolbar ( ) or select Styles command from Create menu.   Song details section of the dialog box allows you to enter title of the song, artist name, and text that will be displayed as your company information (probably something like Presented to you by DOBLON ). Credits are displayed after the song is finished. Tip: To force a new line in Title, Artist, or Company name fields, use ^ character.   What is style? Karaoke Creator allows to set styles for: · Title : image displayed before the song · Credits : image displayed after the song is finished · Song : colors, text formatting, page layout, and image (in Pro version only) of the lyrics   Each of this styles can be applied individually, or it is possible to use presets.   Style preset combo box allows to select one of predefined templates. It will change all styles in Applied styles . You may store your combination of Title, Song, and Credit styles using Add button. To save changed combination use Save button. Delete button removes your preset from the list.   Applied styles lists styles used for each of the sections of the song. To change the style select it in Applied styles list and then choose the new style from Available styles combo. Selecting (Unused) will disable the style.   Style editor button starts Style Editor dialog box which allows you to create your own styles.   Preview window displays the preview of the style selected in Applied styles list.   Selected styles will be applied to the song when you select OK button.   To continue with the tutorial select Rock style preset and click OK button. MODYFYING VIDEO SETTINGS Usually you will want to adjust video parameters to your liking. To open Video Settings dialog box click Video Settings button on the toolbar ( ) or select Video Settings command from Create menu. Input/Output   Input Here you can define the audio track that will be used in the video and choose the background image or video.   There are three possible options for background. You may use a video or image file of your choice, you may use one of the predefined scrolling backgrounds (they are located in %APPDATA%/Doblon/Karaoke Video Creator/Backgrounds folder), or you may use a solid background.   Output This defines the location of video file that will be created. You may choose the format of the video: AVI Windows video file format. Use to play on computer or on DivX-capable players MPEG Universal video format. Use for DVD creation and iPod and iPhone files FLV Flash video. Use for web If  Run default video player when done Karaoke Video Creator will open the newly created file and play it using system's default player for AVI files..   Compression   Video This section defines video compression and frame rate. Compression button allows to choose from video encoders that are installed in the system.   With MPEG encoding selected you may choose one of the predefined MPEG encoding presets (VideoCD, DVD, iPod, iPhone) or choose custom format and adjust all encoding parameters.     Audio Choosing MP3 will result in audio channel encoded to MP3. You may change MP3 encoding parameters with Settings button. Choosing ACM allows to choose from Audio Compression Manager codecs installed on your computer. Use Settings button to select the encoder and adjust the parameters.   Display   Width/Height Defines the resolution of the created video. Set text area button allows to define which part of the video should be used to display lyrics. You may use Common sizes list to quickly select one of common resolutions. Display mode You may also select the text display mode. Choosing Page by page will result in the standard paged display. Overwrite will disable the screen erasing and the new words will overwrite the already sang. And Scrolled mode will generate the long flow of text that will move upwards with the highlighted line always in the middle. Half by half will cause lyrics to appear in turns at the top and at the bottom half of the screen.   Mode information on display modes can be found in Display modes section. Squeeze text and do not break lines When this option is selected Karaoke Video Creator will not break lines -- it will resize it horizontally so every line fits the screen. This may help placing the text in the song, but if the lines are too long may decrease the readability of the text. Vertical alignment Allows to change the placement of the lines of the text. You may select Center, Top, or Bottom which would place the text at the appropriate part of the screen, or choose Space evenly, which makes sure that the first line is at the top, the last at the bottom, and all the spaces between the lines are equal. Horizontal alignment This setting controls the way the individual lines of text are placed. You have the choice of Center, Left, and Right. Font This setting specifies which font will be used for the lyrics and how large the letters should be. If you are trading you PK2 files make sure that you use fonts that are installed on the destination computer. Colors Allows to change the background, border and text color. Simply choose the appropriate color from the list or use More button to select the custom color. Lines per screen Allows to specify the maximum number of lines to be shown. Note that if the font size is too large, the actual number of lines may be lower. Number of highlighted lines to keep If using scrolling or overwrite display mode this parameter controls the number of lines that have already been sung but are not erased yet. Additional spacing The number of pixels to insert between the lines. Outline/Shadow This values control the effect added to the text. Setting them to zero disables the effect. The color of the text effects can be set in Colors dialog box. Word fade time To make the video look better words are faded in when displaying and faded out when erasing. This value controls the time fade takes. Line scroll time This value defines the time used to scroll the lyrics in scrolling display mode. Highlight mode Here you can select whether word should be simply swept with the color or somewhat nicer 'fade' effect should be used. Syllable separator Allows to select the character that separates syllables in the song text. By default the syllable separator is a hyphen (-). Hard space This option allows to change the default character that will be displayed as a space, but does not split the word (e.g. hard_space will be treated as a single word). By default the hard space character is an underline (_). Gradient To make the lyrics look better %APPNAME% applies gradient effect to the text it displays. This setting allows to control the intensity of the effect. Apply blur If you would like to blur the final image, you may define the level of blur to apply. Pan background images with aspect ratio above X If an image selected for the background is at least twice as wide as it is tall, %APPNAME% will scroll it from left to right and back. This creates a very nice visual effect. You may define the speed of the animation. We have provided a set of wide images to use as backgrounds, they are installed with the program.   Title/Credits This group of options allows to select the pictures that are to appear before the song and after the song. By default these pictures are disabled. To learn more about using images in Karaoke Video Creator see Images section.   Presets You may save a current set of options and use it later for different song using the Save button. To invoke the preset select if from a pop-down list. To delete the existing preset use Delete button.   If you would like to use current settings every time you start the program, click Use current as default button. You may also revert to this saved default settings using Reset to default button. It is also possible to revert settings to factory defaults.   DISPLAY MODES Karaoke Video Creator has 4 display modes. Page by page will result in the standard paged display. Full page of lyrics is displayed, and when it is fully highlighted, a new page is presented. Overwrite will disable the screen erasing and the new words will overwrite the already sang. Scrolled mode will generate the long flow of text that will move upwards. Half by half mode causes lyrics to appear in turns on the top and on the bottom half of the screen   WRITING VIDEO FILES Click Create Video File button on the toolbar ( ) or select Create Video File command from Create menu. You may also press F2 key on the keyboard. See the Modifying video settings section if you want to learn more about choosing your video settings.   What's new Karaoke Video Creator is based on Power Video Karaoke, but it introduces many new features. Below are the most important of them. Version 2.2.1. · New user interface   · Shortcut bar   · Styles   ·   Parallel duets   ·   Playback speed change (lower playback for easier synchronization)   · Create New Song wizard   · Countdown event   · Time placement of images   ·   Automatic countdowns   · Squeeze text option   · Improved vocal remover   · Adjust word synchronization   ·   Improved Import MIDI Karaoke Wizard   ·   Search for lyrics on the web   · Search for MIDI Karaoke on the web   · Make lyrics uppercase   · Lyrics export   · Preferences